View Issue Details

IDProjectCategoryView StatusLast Update
0006216OXID eShop (all versions)4.01. Database handlingpublic2015-11-19 08:53
Reporterbrainshack 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.4 / 5.2.4 
Target VersionFixed in Version4.9.7 / 5.2.7 
Summary0006216: Views are broken for language Id > 7
DescriptionHello,

there seems to be an issue with view generation, introduced with this commit:

https://github.com/OXID-eSales/oxideshop_ce/commit/e70479fc8399adec893c9f3ab64cd15d10d1c9fd

Since we updated to 5.2.3, _set tables are no longer used in views, but instead the field in oxarticles will be used. This will lead every of our shops that has a language id > 7 to display all products in the default language. A simple fix for this issue, is to revert the commit posted above. Unfortunately, since we are using the enterprise edition of the shop, we cant fix this issue in our installation.

What basically happens is the following: in getSinglelangFields inside oxdbmetadatahandler, a list of fields is generated by base and language specific fields. When the methods iterates over the list of fields, it will add those to an array. However, since the base fields come after the language fields, the resulting list will always consist of the base fields, and never use the colums from the _set table.
TagsNo tags attached.
ThemeOther
BrowserNot defined
PHP Version5.4
MySQL VersionNot defined

Relationships

related to 0005990 resolvedtadas Unlimited language support does not work 

Activities

There are no notes attached to this issue.