View Issue Details

IDProjectCategoryView StatusLast Update
0006192OXID eShop (all versions)7. --- Other tools --------------public2015-07-16 11:40
Reporterbrainshack 
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.4 / 5.2.4 
Target VersionFixed in Version 
Summary0006192: Fatal error: Class 'modConfig' not found when running testing_library on EE Shop
DescriptionI tried using the https://github.com/OXID-eSales/testing_library on one of our local shop installs. We use the newest EE Version 5.2.4 and the newest unittests aswell, both taken from the partner DL page.

When I run the testrunner, all I get is

Fatal error: Class 'modConfig' not found in oxconfig.php on line 326

I searched the shop sources, the tests sources and the testing_libraries sources and neither of them seem to declare this class, even though it is used quite often.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version5.4
MySQL VersionNot defined

Activities

QA

2015-07-16 11:21

administrator   ~0011103

Last edited: 2015-07-16 11:23

View 2 revisions

This issue most likely occured due to an error in the system requirements of the testing library, which is fixed with the following commit: https://github.com/OXID-eSales/testing_library/commit/604e2998450ce953233410c57f4f1a71f38bcabc

QA

2015-07-16 11:22

administrator   ~0011104

Reminder sent to: brainshack

Please try again using the correct branch and tell us if it works now for you now.

brainshack

2015-07-16 11:33

reporter   ~0011105

Thanks, this seems to work.