View Issue Details

IDProjectCategoryView StatusLast Update
0005998OXID eShop (all versions)4.11. Image handlingpublic2018-03-14 13:50
Reportereike_spriess 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.9.3 / 5.2.3 
Target VersionFixed in Version 
Summary0005998: If option $this->sAltImageDir is set in config.inc.php, new article pictures are no longer generated
DescriptionAlternative URL to remote image server can be specified in configuration file config.inc.php by setting sAltImageUrl and sSSLAltImageUrl.

Thus all product pictures will be loaded from this alternative server instead of the local one.

However, uploaded files will be stored locally. In this case synchronization to external server has to be done manually or with custom scripts.
Additional InformationIf option $this->sAltImageDir = "subdomain/images"; is set in config.inc.php, new pictures are no longer generated from master picture stored locally.

So copying the new pictures to subdomain/images/ did not solve the problem, because pictures were also not generated in /out/pictures/ folder.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Linas Kukulskis

2014-12-15 11:44

reporter   ~0010450

Last edited: 2018-03-14 13:50

View 2 revisions

https://oxidforge.org/en/list-of-configuration-options there are explanation with note