View Issue Details

IDProjectCategoryView StatusLast Update
0005996OXID eShop (all versions)1.03. Basket, checkout processpublic2015-01-08 07:48
Reportergerldental 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
Product Version4.8.9 / 5.1.9 
Target VersionFixed in Version 
Summary0005996: oxbasketitem->getIconUrl() returns standart link in SSL mode
Descriptionoxbasketitem->getIconUrl() returns standart link (http) in SSL mode
Steps To Reproducef.e.: in templates basketcontents.tpl ( line 61 )

<img src="[{$basketitem->getIconUrl()}]" alt="[{$basketitem->getTitle()|strip_tags}]">

on order class returns $basketitem->getIconUrl() a normal link, not htpps.

thats causes an error in IE and warnings in other browsers.
Additional Informationseems to be something wrong in this function:

00390 public function getIconUrl()
00391 {
00392 // icon url must be (re)loaded in case icon is not set or shop was switched between ssl/nonssl
00393 if ($this->_sIconUrl === null || $this->_blSsl != $this->getConfig()->isSsl()) {
00394 $this->_sIconUrl = $this->getArticle()->getIconUrl();
00395 }
00396
00397 return $this->_sIconUrl;
00398 }

maybe $this->_blSsl has a wrong value?
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Version5.3
MySQL Version5.5

Activities

jurate.baseviciene

2015-01-05 09:29

reporter   ~0010566

Reminder sent to: gerldental

Hi,

Sorry we cant reproduce this behavior. Could you please provide to us more details?

We got that oxbasketitem->getIconUrl() returns link in SSL mode not as standard link: <img src="https://testshops/OXID_ESHOP_EE_5.1.9/out/pictures/generated/product/1/87_87_75/rrd_passion_2010_1.jpg" alt="Kite RRD PASSION 2010 ">
        </a>

Best regards,
Jurate

gerldental

2015-01-07 20:01

reporter   ~0010594

on the new hosting we had this problem in all of shops. Now, after few week we can't reproduce this problem too. Please close.

jurate.baseviciene

2015-01-08 07:48

reporter   ~0010595

Hi,

Thank you very much for your an answer. We are very happy that this problem does not exist . We are close this behavior as unable to reproduce.

Best regards,
Jurate