View Issue Details

IDProjectCategoryView StatusLast Update
0005993OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-01-05 12:56
Reporteravalue 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.9.1 / 5.2.1 
Target VersionFixed in Version 
Summary0005993: Discount does not show up in basket
DescriptionDiscounts do not show up in basket summary
Steps To ReproduceSet up a discount for a single user or products. It will not show up in basket summary. I can also reproduce it in the demo shop (PE).
TagsNo tags attached.
ThemeAzure
BrowserGoogle Chrome
PHP Version5.4
MySQL Versionany

Relationships

related to 0005972 resolvedjurate.baseviciene Discount price calculation is wrong when "quantity from" is set from 0 to 1 

Activities

avalue

2014-12-10 10:54

reporter   ~0010398

Video Screencast to reproduce the problem in OXID Demoshop:
https://vimeo.com/114114064 (PW: oxid)

jurate.baseviciene

2014-12-10 15:13

reporter   ~0010411

Reminder sent to: avalue

Hi,

Thanks a lot for submitting this issue.

In this case discount is calculated. In the shop the price is shown with applied discount and no need display discount in the basket.

 It is depends what we are set in quantity from 0 or from 1.
Discounts are displayed in the different place (in the product details page and in the basket).

1. The first test case as you provide to us:
Product price is 129.00,
Discount 15% and quantity from 0 to 999999
Product price is 109,65 EUR <- BECAUSE -we calculate it 129-15%=109,65
In this case discount is apply in the product details page.

2. If you would like to see discount in the basket then you need to use second test case:
Product price is 129,00 EUR.
Need to set quantity from 1 to 999999
In this case discount is apply in the basket.

Best regards,
Jurate

avalue

2014-12-11 10:01

reporter   ~0010420

Last edited: 2014-12-11 10:35

View 2 revisions

@jurate.baseviciene Thanks for your reply. Now I see that the price is recalculated but the discount is never listed as a position in the basket, no matter if I choose From 0 or From 1.

We have another shop running 4.5.x version and there the discount shows up as a position in basket. Is there any way to get this working again?

Also in Backend, there you can read
"Discount: - 0,00 Euro". This is very confusing.

jurate.baseviciene

2014-12-15 14:13

reporter   ~0010457

Reminder sent to: avalue

Hi,

Where to apply discount in basket or in the shop is calculated depending on how is amount from and price is set.

Above I describe 2 test case if discount is assigned for product.
If you would like to see discount not for the product, but for the basket, then you need unassigned all product from discount and amount need to set from =1, then discount would be applied for the shop basket.

Best regards,
Jurate