View Issue Details

IDProjectCategoryView StatusLast Update
0005706OXID eShop (all versions)4.07. Source code, Testpublic2023-11-24 14:41
Reporterarvydas_vapsva 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.5 / 5.1.5 
Target VersionFixed in Version7.0.0-rc1 
Summary0005706: oxConfig::_loadVarsFromDb variables loading issue
DescriptionoxConfig::_loadVarsFromDb:

        if ( !empty($sModule) ) {
            $sModuleSql = " oxmodule LIKE " . $oDb->quote($sModule."%");
        } else {
            $sModuleSql = " oxmodule='' ";
        }

In case you have two themes like "theme1" and "theme1_mobile", one might override other theme config parameters, due to LIKE condition.
TagsTheme Handling
ThemeAzure
BrowserAll
PHP VersionNot defined
Database VersionNot defined

Activities

sse

2014-11-10 08:29

reporter   ~0010322

+1

We have got the same problem...

Sven Brunk

2023-11-24 14:41

administrator   ~0015944

Fixed with https://github.com/OXID-eSales/oxideshop_ce/commit/6a477c985579e106bd874f55be97ed7b0e7f2de4 in 7.0.0