View Issue Details

IDProjectCategoryView StatusLast Update
0005656OXID eShop (all versions)2.3. Extensions (modules, themes)public2014-02-28 23:50
Reportermarcharding 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product Version4.8.3 / 5.1.3 
Target VersionFixed in Version4.7.12 / 5.0.12 
Summary0005656: onDeactivate-Event can't execute ever
DescriptionThe onDeactivate-event defined in metadata.php can't be executed because the module gets remove before the onDeactivate-event is called.

This happens in the oxModule::deactivate Method:_addToDisabledList is called before _callEvent. The order of these two calls must be changed, so that the onDeactivate-Method remains callable.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

There are no notes attached to this issue.