View Issue Details

IDProjectCategoryView StatusLast Update
0005601OXID eShop (all versions)3. ----- eShop theme - Azure ------public2014-01-13 09:20
ReporterMitmacher 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.8.1 / 5.1.1 
Target VersionFixed in Version 
Summary0005601: Missing theme switcher in Azure?
DescriptionIf you have installed oethemeswitcher than it overrides the block "layout_page_vatinclude" in "layout/page.tpl" to include a large (orange) button at the top for switching to mobile. Unfortunately that doesn't work because there seems to be a little mistake in "theme_switch_link.tpl":

[{if $oUserAgent->getDeviceType() == 'mobile' }]

That should be:

[{if $oUserAgent->getDeviceType() == 'desktop' }]

and the button will be shown as obviously wanted... :-)
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

Mitmacher

2014-01-12 14:16

reporter   ~0009406

Further it may be better to use "[{$oView->getLink()}]" instead of "[{oxgetseourl ident=$oViewConf->getSelfLink()}]" in both switching forms to keep the user in the current context. Otherwise he will be redirected to start each time.

Mitmacher

2014-01-12 22:10

reporter   ~0009407

Oh dear, I was totally wrong with this bugreport, sorry! Of course the mentioned button in Azure should be shown only if you are using a smartphone and want to switch back to Mobile. Thanks to nickname for clearing this point in the forum! :)