View Issue Details

IDProjectCategoryView StatusLast Update
0005555OXID eShop (all versions)2.6. Administer orderspublic2014-03-04 11:25
ReporterJE-B 
PriorityhighSeveritycriticalReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.7.8 / 5.0.8 
Target Version4.7.10 / 5.0.10Fixed in Version 
Summary0005555: VAT calculation is wrong after setting payment date
DescriptionIf you set the payment date on the order_overview Tab, the whole order is recalculated (see 0005113). If a voucher with a percental discount was used, then the VAT will not be correct after that. Our client is experiencing this in EE 5.0.8 but it can also be reproduced in the current PE Demoshop (see below).
Steps To Reproduce* Go to OXID Demoshop
* Open Admin Interface
* Create a voucher serie with a percental discount (for example 25%) and some corresponding vouchers
* In shop frontend, add articles to basket
* In basket view, apply voucher
* Go through checkout
* Check the order in admin - all values are fine (see left side of attached file screenshot.png)
* Switch to order_main tab and set the payment date
* Switch back to order_overview tab - the values for article net price and vat have changed and are now wrong (see right side of attached file screenshot.png)
TagsVAT
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005113 resolvedHR Full Recalculation of order if payment date is set 

Activities

JE-B

2013-12-04 16:21

reporter  

screenshot.png (175,605 bytes)
screenshot.png (175,605 bytes)

jurate.baseviciene

2013-12-05 08:33

reporter   ~0009333

Hi,

Bug is closed as duplicate of 0005113.

Best regards