View Issue Details

IDProjectCategoryView StatusLast Update
0005428OXID eShop (all versions)3.1. Design, GUI, UXpublic2013-10-31 10:48
Reportermario_lorenz 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.7 / 5.0.7 
Target Version4.9.0_5.2.0_beta1Fixed in Version 
Summary0005428: Azure-Template "itemsperpage.tpl": "ldtype" has an unexpected value in manufacturer-lists
DescriptionIn the itemsperpage-Links i expect that the ldtype has on of the correct listtypes: grid, infogrid, line.

In the normal article-lists is this Ok. But not when you come from a manufacturer-List.

Steps To ReproduceWhen you enter a list with articles from a manufacturer-Link:
eg: http://demoshop.oxid-esales.com/community-edition/Nach-Hersteller/ION/

Then the value of "ldtype" is "manufacturer". This is in my opinion not correct. Because when you change now the "items per page". You will lost the choosen Listtype.

Additional InformationMy Solution:

Add in the Top of this Template:
[{assign var="_listType" value=$oView->getListDisplayType()}]

and change:

ldtype=$listType

to:

ldtype=$_listType
TagsManufacturer
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

jurate.baseviciene

2013-09-23 07:34

reporter   ~0009106

Reminder sent to: mario_lorenz

Hi,

Thank you very much for your bug report. As we saw, you already submitted a complete solution for this issue. If you feel fancy, you'd also have the possibility to contribute your changes directly to our GitHub repository on https://github.com/OXID-eSales/oxideshop_ce/. [^] [^] Please leave a note there with the bug number you fixed so we can close this issue in the bug tracker.


Best regards

mario_lorenz

2013-09-24 10:32

reporter   ~0009109

Last edited: 2013-09-24 14:43

View 2 revisions

Hi,

i've commit and push the fix via Github:

https://github.com/mariolorenz/oxideshop_ce/commit/486f4746d77f87e47e6cc975be35fc79c1cd97dc

Best regards