View Issue Details

IDProjectCategoryView StatusLast Update
0005412OXID eShop (all versions)2.4. Administer productspublic2013-09-16 12:37
Reporterequinox 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version4.7.7 / 5.0.7 
Target VersionFixed in Version 
Summary0005412: articles => article attributes => add attribute: ajax filter not working
Descriptionalways displays no result, no matter what is entered
Additional Information
ori code in ajaxListComponent:

    /**
     * Adds filter SQL to current query
     *
     * @param string $sQ query to add filter condition
     *
     * @return string
     */
    protected function _addFilter( $sQ )
    {
        if ( $sQ && ( $sFilter = $this->_getFilter() ) ) {
            $sQ .= ( ( stristr( $sQ, 'where' ) === false )?'where':' and ' ) . $sFilter;
        }
        return $sQ;
    }

bugfix:

change:
?'where':' and '
to:
?'where ':' and '

cheers!
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

jurate.baseviciene

2013-09-16 11:53

reporter   ~0009087

Reminder sent to: equinox

Hi,
Thanks a lot for submitting this issue, but unfortunately we can not reproduce this issue. Could you please let us know if you still experience same problem on our demo shop http://demoshop.oxid-esales.com/EnEd/admin ? Could you send us more details about it?

I try to reproduce:
- Go to Articles Products -> Products ;
- Choose the product for example 1402;
- Select tab "Selection"
- Then click on the button Assign Attributes and ajax filter we checked everything working

Best regards




equinox

2013-09-16 12:17

reporter   ~0009088

weird,
then it might be caused by custom code!?

I must further look into this issue.

cheers

jurate.baseviciene

2013-09-16 12:37

reporter   ~0009089

We can't reproduce such issue. If in the future this bug will be reproduced please bug status change to "Reopen". And please written for more details how bug need reproduce.

Best regards