View Issue Details

IDProjectCategoryView StatusLast Update
0005387OXID eShop (all versions)5. ------ UpdateApp / Update ------public2013-09-25 16:29
Reportermartinwegele 
PrioritylowSeveritytweakReproducibilitysometimes
Status resolvedResolutionwon't fix 
Product Version4.7.0 / 5.0.0 revision 51243 
Target VersionFixed in Version 
Summary0005387: Redirection to setup
DescriptionIf you try to run the update app and the shop was not installed yet (config.inc.php contains "<dbHost" etc.) oxdb.php will try to redirect you to /updateApp/ui/http/setup/index.php which does not exist in the updateApp.
This is because oxDb::_onConnectionError() uses a relative path for the redirect. Is it possible to do the redirection to the setup with an absolute (=complete) URL like http://shop.tld/(subdir/)setup/index.php?
Steps To Reproduce1. Extract all shop files from the installation package into a dir
2. extract the update app into the same dir
3. Start the update app.
Additional InformationI know that this is an extremely unlikely constellation/situation but it happened to a customer during the update from 4.6.5 to 5.0.0 and caused some confusion. I could imagine other situations where it would be difficult to debug the behaviour, too, so it might be worth to consider fixing this bug.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

There are no notes attached to this issue.