View Issue Details

IDProjectCategoryView StatusLast Update
0005297OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-02-21 12:06
ReporterJE-B 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target Version4.8.5 / 5.1.5Fixed in Version4.9.0_5.2.0_beta1 
Summary0005297: Articles per page does not work when "grid" is selected as standard view
DescriptionIf the default setting for category view is set to "Grid" ("Galerie" in german) the "Articles per page" chooser does not work until the layout of the category is changed. I was able to reproduce this behaviour on the demoshop.
Steps To ReproduceIn demo shop ...

1. Go to admin
2. Navigate to "Extensions / Themes"
3. Select "Azure"
4. Click on "Settings"
5. Select "Grid" for "Default product list type" and "Product list type on Start page"
6. Click "Save"
7. Delete your session cookies or restart your browser
8. Go to shop frontend and navigate to a category of your choice
9. Make a selection in "Articles per Page". It won't work since it seems to display the wrong list

However, after changing the display type via the frontend and switching back to grid view, it works. The reason seems to be, that the session variable "ldtype" is not set.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Activities

There are no notes attached to this issue.