View Issue Details

IDProjectCategoryView StatusLast Update
0005265OXID eShop (all versions)2.4. Administer productspublic2013-07-02 14:14
Reportervschmi 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.7.6 / 5.0.6 
Target VersionFixed in Version 
Summary0005265: Popup for "Stock" grabs focus
DescriptionOriginal bug report to me: "I can't click the Stock field in Admin->Articles->Stock because the field hint for the stock field is overlapping, thus I can't enter any values inside it!"

The JS tooltips created with "popUp" and "popDown" are sometimes placed within the field. So the popUp/popDown functions should make sure that they're always outside of the field, because at least on Safari the popups grabs the user input.

Even worse, the "Stock" field is placed at the very top of the frame, so the popup has no place to go and blocks the field all the time. This behaviour has been reproduced in Chrome, however, the user can click through. With Safari, he can't.

To migitate that behaviour I simply removed the popups in article_stock.tpl for my customer. In addition to the bug occuring in Safari, the popups should really be delayed as well as go away then clicked.
TagsNo tags attached.
ThemeBoth
BrowserGoogle Chrome, Apple Safari
PHP Versionany
MySQL Versionany

Activities

tomas.lygutas

2013-07-02 14:14

reporter   ~0008866

Added positioning of popups to the right side of field.