View Issue Details

IDProjectCategoryView StatusLast Update
0004884OXID eShop (all versions)1.05. Userspublic2013-02-01 09:35
Reporter[email protected] 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Platformdoesn't matterOSdoesn't matterOS Version
Product Version4.6.0 revision 44406 
Target VersionFixed in Version 
Summary0004884: oxUtils::isValidEmail($email) not conform with RFC 2822
DescriptionSome characters which are allowed in valid e-mail Adresses are not allowed by the implementation of oxUtils::isValidEmail($email).

Allowed Characters would be: A-Za-z0-9.!#$%&'*+-/=?^_`{|}~
Characters that are in fact allowed by Oxid esales are: [A-Za-z0-9_\-\.]
Steps To Reproducetry to register with an e-mail address that contains a "+" character
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0003755 resolvedsaulius.stasiukaitis Wrong valdiation for email-adresses with an ampersand or other special chars 
related to 0005713 resolvedsaulius.stasiukaitis New TLDs are not accepted by oxinputvalidator 

Activities

There are no notes attached to this issue.