View Issue Details

IDProjectCategoryView StatusLast Update
0004870OXID eShop (all versions)4. ------ eShop Core -------public2013-01-24 14:49
Reportermichael_keiluweit 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version4.7.2 / 5.0.2 revision 53018 
Target VersionFixed in Version 
Summary0004870: oxUtils->isValidEmail does not allow RFC allowed characters
DescriptionThe method oxUtils::isValidEmail does deny some characters which are described and allowed bei the RFC document 5322: http://tools.ietf.org/html/rfc5322#section-3.2.3
TagsNo tags attached.
ThemeBoth
BrowserFireFox 6.x
PHP Versionany
Database Versionany

Relationships

duplicate of 0003755 resolvedsaulius.stasiukaitis Wrong valdiation for email-adresses with an ampersand or other special chars 
related to 0005713 resolvedsaulius.stasiukaitis New TLDs are not accepted by oxinputvalidator 

Activities

There are no notes attached to this issue.