View Issue Details

IDProjectCategoryView StatusLast Update
0004822OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2014-03-12 16:19
Reportercbatik 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.6.3 revision 47975 
Target Version4.8.5 / 5.1.5Fixed in Version 
Summary0004822: Redirect when stock of variant is 1
DescriptionThe product page is not accessible and you will be redirected with the following configuration:

- master product has oxstockflag = 2
- all variants has oxstockflag = 3
- all variants are out of stock (oxstock = 0)
- only 1 variant has a stock of 1 (oxstock = 1, with oxstock = 2 it works!)
TagsStock, Variants
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0004968 resolvedLinas Kukulskis stocklevel set to -1 when creating new product 
has duplicate 0005413 closedjurate.baseviciene Active snippet doesn't give you all active parent products of variants 

Activities

jurate.baseviciene

2013-01-07 09:35

reporter   ~0008225

Reminder sent to: cbatik

Hi,
Sorry, but we can not reproduce the case.
Could you please try to reproduce that on our demo shops:
http://demoshop.oxid-esales.com/community-edition/?

I try to reproduced:
1. First off all I set for product(3570) oxstockflag = "If out of Stock, offline";
2. All variants has oxstockflag = ("If out of Stock, not orderable");
3. All variants has(oxstock = 0);
4. Only 1 variant(W 30/L 30 | Blau) has a stock of 1 and it works.

Best regards,

cbatik

2013-01-07 14:36

reporter   ~0008232

Last edited: 2013-01-07 14:36

View 2 revisions

For example, see http://demoshop.oxid-esales.com/community-edition/Bekleidung/Fashion/Fuer-Ihn/Jeans/Kuyichi-Jeans-KYLE.html

Variant mit ArtNum 0601-85-069-8-1 hast oxstock = 1. All other variants have oxstock = 0. And the master article hast oxstock -1 and oxstockflag = 2

henrik.steffen

2014-02-21 09:46

reporter   ~0009572

please find detailed description why this happens here:

https://bugs.oxid-esales.com/view.php?id=5413

Linas Kukulskis

2014-03-12 16:19

reporter   ~0009641

fixed with 0004968 fix