View Issue Details

IDProjectCategoryView StatusLast Update
0004808OXID eShop (all versions)1.05. Userspublic2014-03-04 11:29
Reportersolidevolution 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.6.5 revision 49955 
Target VersionFixed in Version 
Summary0004808: Wrong Shop ID while using oxuser::addToGroup in Frontend
DescriptionSince we migrated from CE 4.6.5 to EE 4.6.5, the static method oxuser::addToGroup() saves the wrong shop id.

In 1 master, n subshop context, it saves the id of the subshop into oxobject2group, so that the automatic discount on a group doesn't work for a customer.
Steps To Reproduce1. Create a customer group
2. Create a percent discount for that customer group
3. Implements the addToGroup() Method in Frontend
TagsNo tags attached.
ThemeAzure
BrowserGoogle Chrome
PHP Version5.3
MySQL Version5.1

Activities

Linas Kukulskis

2012-12-19 16:10

reporter   ~0008180

its saves active shop id in which user was added to group. its default behavior