View Issue Details

IDProjectCategoryView StatusLast Update
0004630OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-11-19 09:06
ReporterzuernBernhard 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLAMPPOSUbuntu LinuxOS Version12.04 LTS
Product Version4.6.4 revision 49061 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0004630: Can't Upload Pictures for Products in the Backend for Products which do not already have a picture
DescriptionWhen you have Products without Pictures there is no path like out/master/product/2 so the move_uploaded_file will fail because the target-dir does not exist.
Steps To Reproducecreate a Product wihout images, go to this product in the shopbackend and try to upload an image
Additional Informationalready fixed that locally by adding:

{
         $blDone = false;
 
+ if (!is_dir(dirname($sTarget))){
+ mkdir(dirname($sTarget), 0744, true);
+ }
+
         if ( $sSource === $sTarget ) {
             $blDone = true;
         } else {

to the method protected function _moveImage( $sSource, $sTarget ) in core/oxutilsfile.php
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Version5.3
MySQL Version5.1

Activities

There are no notes attached to this issue.