View Issue Details

IDProjectCategoryView StatusLast Update
0004627OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-10-16 12:46
Reporterrr 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.6.5 revision 49955 
Target VersionFixed in Version4.6.6 revision 54646 
Summary0004627: Typo in shop_config::_serializeConfVar() when fixing float values
DescriptionIn OXID eShop 4.6.5, there is a typo in the _serializeConfVar() method of shop_config.php (line 343):

case "str":
case "select":
case "int":
    if (in_array($sName, $this->_aParseFloat)) {
        $mData = str_replace( ',', '.', $mData ); // typo: $mValue instead of $mData
    }
    $sData = $mValue;
    break;

The line that fixes the comma in the float string should use the variable $mValue instead of $mData. I just stumbled upon this typo because my IDE highlighted the typo ;-)

The same typo exists in the RC1 of OXID eShop 4.7.0 (on line 344).

The problem is not really severe, because apparently no one noticed that float values with a comma are not correctly fixed ;-)
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

There are no notes attached to this issue.