View Issue Details

IDProjectCategoryView StatusLast Update
0004010OXID eShop (all versions)4.02. Session handlingpublic2012-05-23 15:20
Reportertjungcl 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.10 revision 44222 
Target VersionFixed in Version4.6.1 revision 45706 
Summary0004010: force_sid added in https to every link
Descriptionwhen you have a shop with https, you'll have force_sid parameters on nearly every link.

(not reproducable in demoshop, because its not available in https)

Bug lies in the two regex patterns in oxconfig.php -> isCurrentUrl

Wrong:
/^(http:\/\/)?([^\/]+)/i

Correct:
/^(https?:\/\/)?([^\/]+)/i

Additional InformationPlease fix soon in 4.5.9/10, because i' not yet willing to update to 4.6 and oxconfig.php is not extendable, so this cant be fixed with a module, thanks.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0003929 resolvedvaidas.matulevicius [EE-only] Mall ssl url detection is broken 

Activities

There are no notes attached to this issue.