View Issue Details

IDProjectCategoryView StatusLast Update
0003873OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
Reporterray 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version4.5.9 revision 43186 
Target VersionFixed in Version 
Summary0003873: wrong amount after editing order when used coupon is no longer present
DescriptionCustomers have ordered some items and have used a coupon/voucher so they got some discount. Now after some time the voucher is not valid any longer and was deleted. If customers send back parts of their order and those orders are edited (delete items which where sent back) the total amount is wrong as it does not take note of the discount which was granted formerly.
Steps To Reproduce- create a discount coupon
- make an order with three or four items using that discount
- delete discount coupon
- edit order and delete one item

-> new amount is wriong without the discount
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2012-06-05 16:41

reporter   ~0006782

It's not an issue, but expected behavior. In any case, when you do update of existing order in admin - it always recalculates all order according to current circumstances. Means - if any detail is changes since the date when order was placed - it will take latest values of that and apply to the order.
So in this case we suggest to not delete the vouchers which are expired already, but leave it for history purposes and cases like that.

dainius.bigelis

2012-06-05 16:57

reporter   ~0006783

Last edited: 2012-06-05 16:57

View 2 revisions

as one more solution for that case also would help this feature:
http://oxid.uservoice.com/forums/31940-feature-requests/suggestions/2904314-allow-manual-editing-of-total-discount-and-additio