View Issue Details

IDProjectCategoryView StatusLast Update
0003729OXID eShop (all versions)4.11. Image handlingpublic2014-01-06 13:33
Reporterb.hasis 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.5.8 revision 42471 
Target VersionFixed in Version 
Summary0003729: Image size handling in oxDynImgGenerator
Descriptionhello,

if i adding a new image-size for Products like in this thread explained (post no.3 http://www.oxid-esales.com/forum/showthread.php?t=12877) the folder for this new size will be not generated by OXID because of core/oxDynImgGenerator.php fnc:_isValidPath() and a "hard" filled array (_aConfParamToPath).

So my new size doesnt valid because it isnt in _aConfParamToPath. I have to modify this core file to make my folder dynamic generated.

Can you make _aConfParamToPath dynamic by getting the possible image sizes from the database (from oxconfigdisplay)?
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

andrius.silgalis

2012-11-22 09:51

reporter   ~0007946

The specified image size folder gets generated correctly.

Linas Kukulskis

2014-01-06 13:33

reporter   ~0009380

to use custom image size configuration, please write your own image generator (or extend existing) For more details how to register and use custom image generator:
http://wiki.oxidforge.org/Tutorials/image_handling_changes