View Issue Details

IDProjectCategoryView StatusLast Update
0003472OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2012-12-07 15:19
Reportermichael_keiluweit 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.5.6 revision 40808 
Target VersionFixed in Version4.8.0_5.1.0_beta1 
Summary0003472: shop calculates VAT with a komma seperated number wrong
Descriptiongoto: shop admin -> stammdaten -> grundeinstellungen -> Einstell. -> Mehrwertsteuer (VAT)

Insert a number like 19.6
shop calculates correct.

A number like 19,6 will correctly displayed in the input field in the settings menue, but the whole shop calculates with 19. After executing an order, you can see it also in the oxorder table. Please have a look at the attached screenshot.
1. line: 19.6
2. line: 19,6

As a solution:
Try to detect what is local decimal separator and use this one for detecting the proper number inserted. If not possible (or would be incorrect) to track local decimal separator - do not allow to insert the comma in number. In this case display the proper error message informing about that instantly.
Additional Informationtested in ee demoshop

shop should parse a komma into a point, because it is self-evident to write a komma instead a point.
TagsVAT
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005840 closed false dDefaultVAT vat type 

Activities

michael_keiluweit

2012-01-02 13:39

developer  

vat.PNG (8,356 bytes)
vat.PNG (8,356 bytes)