View Issue Details

IDProjectCategoryView StatusLast Update
0003167OXID eShop (all versions)4.07. Source code, Testpublic2012-12-10 13:44
Reporterboehme 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version4.5.10 revision 44222 
Summary0003167: lists loading incomplete objects without setting lazyloading = true
Descriptionlets use oxCountryList as example:
we want to load the list using loadActiveCountries(). The method selects the fields oxid and oxtitle from database and sets only this fields to the objects cloned in oxList::selectString(). If we want accesss other fields, for example oxvatstatus for the isInEU-method (with actually will allways return false), we will get bool(false) instead of an oxField-object.
The reason for this behavior is that the _blUseLazyLoading-flag is not set to the baseObject.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Activities

Linas Kukulskis

2012-04-12 14:41

reporter   ~0006242

the main idea how to get additional fields for list of object which not using the lazy loading is to overwrite query with additional fields by module, but not turning ON lazy loading.