View Issue Details

IDProjectCategoryView StatusLast Update
0002871OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2012-12-07 14:13
ReporterMitmacher 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.5.0 revision 34568 
Target VersionFixed in Version 
Summary0002871: Curious behaviour in function getNrOfArticles()
DescriptionI can't get the logic behind the fact that the admin option blDontShowEmptyCategories may "overwrite" perfShowActionCatArticleCnt in function getNrOfArticles() inside oxcategory.php. There where made many changes from 4.4 to 4.5 and obviously something goes wrong now. Unfortunately it is not enough to delete the line 438:
|| $myConfig->getConfigParam('blDontShowEmptyCategories')
as I thought first (the result was that NO category was shown any more). The problem is more complex and I am not able to find a workaround for this.
Steps To ReproduceIn admin panel go to performance settings and activate blDontShowEmptyCategories and DEactivate perfShowActionCatArticleCnt. The shop frontend now still shows the category article counts in brackets which is logically wrong.
TagsCategory
ThemeBoth
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0002753 resolvedLinas Kukulskis with option "don't show empty categories" on, number of articles in categories are shown, even if switched off 

Activities

There are no notes attached to this issue.