View Issue Details

IDProjectCategoryView StatusLast Update
0002679OXID eShop (all versions)1.03. Basket, checkout processpublic2012-12-10 14:13
Reportermbrotzeller 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntelOSOpenSuseOS Version11.3
Product Version4.4.6 revision 32697 
Target VersionFixed in Version4.5.3 revision 39087 
Summary0002679: Incorrect checking of delivery rule
DescriptionProblem:
If there is one product in the basket that has a zero price, we want to suppress calculating delivery costs.

Idea:
Create a rule, that ckecks every article for a price => 0 and <= 0, make this rule final and put it on top of the queue.

Outcome:
If there is only one product in the basket, the price is not calculated for this rule - instead 0 is assumed
Steps To ReproduceCreate a delivery rule - active, no date, no groups, no categories, price between 0 and 0, once per product or once per item, final.
Add the rule to a delivery set such that it is processed as first rule.
Add one product for a non-0 value to the basket, choose the deliveryset.

Additional InformationOn a side note, an abs price does not get added, a relative one does.

I checked the code (can't paste it here since i'm bound by an NDA), narrowed it down to oxdelivery.php line 426pp - i think the two lines starting with "if" need to get swapped, so that the price of the product gets added to the total, else the block that follows the #M1130 comment thinks the sum is still 0.

I still run 4.4.6, but the code in question did not change to 4.4.8
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Activities

There are no notes attached to this issue.