View Issue Details

IDProjectCategoryView StatusLast Update
0002203OXID eShop (all versions)4.07. Source code, Testpublic2010-11-29 10:40
Reporterdominik_ziegler 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version4.4.4 revision 30554 
Target VersionFixed in Version4.4.5 revision 31315 
Summary0002203: Unit testing can not find class oxFb
DescriptionEach time i want to run the complete unit test procedure, I get a fatal error that the script could not find the oxFb class and aborts the whole test scenario. Therefore it is not possible to execute this test successfully.
Steps To ReproduceFatal error: Class 'oxFb' not found in [path]/unit/core/oxfbTest.php on line 59
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

dominik_ziegler

2010-11-09 17:45

reporter   ~0003677

I have identified the problem. It seems unit testing crashes if cURL is not installed on the server. I've tested that with the official VMware for module certifications and had to reinstall ist.

Unfornutately there is another problem with a maintenance test file:

 Unit_Maintenance_priceCalculationTest
 ...
Fatal error: Call to a member function getId() on a non-object in /var/www/oxid/core/oxbasketitem.php on line 321

It seems that there is no oxArticle object at $this->getArticle().

birute_meilutyte

2010-11-18 13:01

reporter   ~0003710

can not reproduce the problem.

@developers: check from source code side, maybe there is some special server configuration required like with oxfbTest case

arvydas_vapsva

2010-11-29 10:40

reporter   ~0003749

Please re-run shop setup and reinstall shop after you get any "Fatal error" while runing tests, because some trash data is left, which breaks tests.