View Issue Details

IDProjectCategoryView StatusLast Update
0001923OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2015-05-04 14:15
Reportertabsl 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionsuspended 
Product Version4.3.2 revision 27884 
Target VersionFixed in Version 
Summary0001923: falset NET PRICE and VAT by itembased coupons
Descriptionwehn you use an itembased or categorybased coupon, the NETPRICE and VAT is not calculed correctly

the calculation on the NETPRICE inlcudes the voucher, but taht´s wrong.
the coupon is deducted only on the BRUPTICE at last
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Activities

dainius.bigelis

2010-06-18 14:58

reporter   ~0003191

Reminder sent to: tabsl

Hi,

Do you mean incorrect numbers in the basket? or the calculation itself in the source code?

Best regards,

tabsl

2010-06-18 15:32

reporter   ~0003194

the calculation (the displayed prices)

dainius.bigelis

2010-06-18 16:03

reporter   ~0003195

Reminder sent to: tabsl

Strange. Because for it looks well. I.e.:
Added product A (from category B) to basket with (bruto) price 100 EUR.
Then added the abs (-10 EUR) coupon, which is setuped for category B to the basket.
So in the basket I have such amounts:
Product 100 EUR
Total Products (net): 75.63 EUR
plus VAT 19% Amount: 14.37
Total Products (gross): 100 EUR
Coupon -10.00 EUR
Grand Total: 90.00 EUR.

So Coupon amount is removed from Bruto price. The Net price and VAT looks good.
The same behavior is with the coupon set with % (instead abs).
Or I misunderstood something?

tabsl

2010-06-18 16:09

reporter   ~0003197

the 100 eur NET PRICE should be 84,033 EUR (or not)?

dainius.bigelis

2010-06-19 10:49

reporter   ~0003205

Reminder sent to: tabsl

Hi,

Looks like there are some exceptions for calculating vouchers in the basket, when these are assigned to particular products.
So now we gonna check these cases with our tax consultants and then consider about proper solution.

Thank you for your report.
Best regards,

dainius.bigelis

2010-06-19 10:51

reporter   ~0003206

Entry is suspended until we will check how it should work.