View Issue Details

IDProjectCategoryView StatusLast Update
0001524OXID eShop (all versions)4.10. AutoLoaderpublic2014-02-20 08:29
Reportertomas_liubinas 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target Version4.8.5 / 5.1.5Fixed in Version 
Summary0001524: Problems with not automatically initialised modules
DescriptionThe bug is quite rare and it happens on the following conditions:
one of module names is the part of other module name
AND
when shorter module parent is not loaded over __autoload
AND
shorter module is defined AFTER the longer one in admin module list (1/2)
AND
longer module is initialised BEFORE shorter one

In this case class not found exception is thrown.

example modules:
ajaxcomponent => myCategoryOrderAjax
category_order=> myCategoryOrderController
Additional InformationThe reson of class name confusion seems to be stripos() check in oxfunctions.php line 66.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Activities

vilma_liorensaityte

2014-02-20 08:28

administrator   ~0009537

was unable to reproduce with the newest code...