View Issue Details

IDProjectCategoryView StatusLast Update
0001501module PayPalmodule PayPal - subpublic2012-12-10 16:11
Reporterarvydas_vapsva 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001501: Problems with curl_setopt($ch, CURLOPT_VERBOSE, 1); in efi_paypal_caller_service.php
DescriptionOn one client server option curl_setopt($ch, CURLOPT_VERBOSE, 1); causes problem, due to some strange server config and STDERR. So output cant be written to STDERR.
Additional InformationThere are to ways to solve problem:

1. comment this code line;
2. direct output to some log file like:

    $oFileHandle = fopen( _SOME_LOG_FILE_, "w" );
    curl_setopt($ch, CURLOPT_STDERR, $oFileHandle );
    
    ...
    $sResponse = curl_exec($ch);
    fclose( $oFileHandle );
TagsNo tags attached.

Activities

There are no notes attached to this issue.