View Issue Details

IDProjectCategoryView StatusLast Update
0001486OXID eShop (all versions)2. ----- eShop backend (admin) -----public2009-11-18 14:12
ReporterOliver Storm 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version4.2.0 revision 23610 
Target VersionFixed in Version4.3.1 revision 27257 
Summary0001486: "Moderate Product Reviews" does not work as Reviews are always displayed in frontend
DescriptionConfiguration
----------------------------------------
eShop Admin
Master Settings -> Core Settings -> System
[] Moderate Guestbook and Product Reviews: They are only published after they are activated by an Administrator User
    

Frontend
----------------------------------------
Login
=> go to a Product
Box: Write Product Review
-> Write a review.

But the Review will be displayed
"Hans writes: Time: 21:11 Date: 17.11.2009 Rating: 3
    teste
"

thought in Admin -> Products -> Review tab - the option "Active" is still not selected.
Looks like check if "Active" is missing in article details page.
TagsReviews
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0001449 resolvedarvydas_vapsva Multiple entries in oxreviews when pressing F5 after writing a review with rating 

Activities

2009-11-17 21:25

 

dainius.bigelis

2009-11-18 10:48

reporter   ~0002098

Reminder sent to: Oliver Storm

Hi,

Here are two issues:
1. Review does not depend on option "Moderate Guestbook and Product Reviews" and is displayed always after it is inserted (thought in Admin option "Active" is OFF). This should be fixed.
2. The double entries occurs in the DB after activation - I cannot reproduce this case: when the entry got activated - only OXACTIVE value was changed in DB, but other record didn't appeared. Double entries may occur because article details page was refreshed just after review was inserted (so it inserted it again). This issue is reported in 0001449 and is already fixed (will be released in Next Major release).
So I change description to fix the 1st issue.

Thank you for report.

arvydas_vapsva

2009-11-18 14:12

reporter   ~0002102

Not a bug. Moderation works.

Test this case:

- enable moderation;
- go to product details;
- enter review.

Until you logged-in reviews written by you will be shown, if you log off - reviews are gone. ONLY review owner will see it until shop admin will mark it as active.