View Issue Details

IDProjectCategoryView StatusLast Update
0001409OXID eShop (all versions)3.1. Design, GUI, UXpublic2009-10-23 12:48
Reporteralfonsas_cirtautas 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.1.6 revision 22740 
Target VersionFixed in Version4.2.0 revision 23610 
Summary0001409: Blank new lines before DOCTYPE in product details causes problems for IE
DescriptionIE can't determind doctype corecltly if it is not in the first line, then it just switches to quirks mode
TagsNo tags attached.
Theme
BrowserInternet Explorer 6.x or older
PHP Version5.2.6
Database Version5.0.33

Activities

alfonsas_cirtautas

2009-10-21 11:47

reporter   ~0001943

The problem can be seen not only in details page.

The problem was Smarty leaving newline and whitespace characters if _header.tpl was included non in first line (in some cases it is not possible to do, if some variable assigns are needed to pass to header include)

The fix is simple, ltrim output.