View Issue Details

IDProjectCategoryView StatusLast Update
0001395OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2015-05-04 14:43
ReporterBergfreunde 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.6 revision 22740 
Target VersionFixed in Version4.2.0 revision 23610 
Summary0001395: DB field oxvarminprice is not updated when lowest price article goes Offline
DescriptionI asked the support for the function of oxarticles.oxvarminprice.
Normaly it should be used when an article has variants and the mainarticle isn't purchasable. So the mainarticle should have saved the lowest price of all articles in this field. When a variant runs out of stock this field should be recalculated.

As far as i could test it the field doesn't get a value. In shop-frontend the minprice seems to be calculated in realtime what's very bad for the performance.

This is either a bug or a missing function.
TagsProducts, Variants
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Activities

dainius.bigelis

2009-10-22 15:30

reporter   ~0001963

It's the bug that OXVARMINPRICE is not recalculated after one of variants goes out of stock. It should be recalculated in such case.

@Developers:
Please also check if the value from DB can be used instead of calculating it realtime in frontend.

Bergfreunde

2009-11-05 10:41

reporter   ~0002009

In my testcase the OXVARMINPRICE didn't even get a value after creating a mainarticle with variants in shopadmin. But that was with version 4.1.6, maybe it is already fixed?

dainius.bigelis

2009-11-12 21:50

reporter   ~0002061

Reminder sent to: Bergfreunde

Hi,

I still can reproduce the case in 4.1.6, but cannot reproduce it any more in eShop version 4.2.0 (tested with EE and PE). Probably this issue gone together with some other fixes.
So this entry is closed as Fixed in version 4.2.0.
If this issue will occur in future - please reopen this bug entry.

Thank you for your report.

Best regards,

Bergfreunde

2009-11-17 12:26

reporter   ~0002078

I created Mainarticle and added 2 Variants (40€ and 50 €)
--> OXVARMINPRICE is 40 now

So far it is correct.

But this value doesn't change any more.
I set stock of 50€-Variant on zero and oxstockflag="2" (when sold offline).
In frontend the Mainarticle gets signed with 50€ now (correct), but in DB the OXVARMINPRICE is still 40€.

Same, when I delete the 50€-Variant or create a new Variant with lower price.

So the OXVARMINPRICE doesn't update and the min-price in frontend still seems to be calculated in realtime

dainius.bigelis

2009-11-17 14:59

reporter   ~0002083

Reminder sent to: Bergfreunde

Hi,

So - I retested it once again exactly as you said (on EE 4.2.0, with parent and variant articles from demodata, and with newly created products). On all these cases (set stock to zero, changing condition to "If out of stock, offline", also deleting variant) - on all these cases the oxvarminprice was updated in the DB for parent article.

To make it fully clear - are you testing this on eShop version 4.2.0?

Best regards,

Bergfreunde

2009-11-18 11:33

reporter   ~0002099

Hi,

I retested it again with a new produkt with variants and it worked like u said. So i took my old product again but with that one i still have my described problems. I checked for any difference in the Database, but didn't find one.

With that old one the oxvarminprice just doesn't get updated any more.
I'm completely mystified...


p.s: Yes, I am testing with Version 4.2.0.

dainius.bigelis

2009-11-18 14:03

reporter   ~0002101

Reminder sent to: Bergfreunde

Hi,

Then it's possible that problem occurs only on your shop, because some incorrect data or installed additional modules. Anyway - would be good to check it to be sure. For that would be best if you would write request to our suppor system ([email protected]) or give us dump of your shop DB, with details how you can reproduce that (on which particular article).

Best regards,