View Issue Details

IDProjectCategoryView StatusLast Update
0001376OXID eShop (all versions)6. ------ Setup -------public2009-10-23 12:58
Reporterdainius.bigelis 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.2.0 revision 23610 
Summary0001376: Problem because safe_mode=OFF and check for open_basedir status is needed in sys requirements
DescriptionIn system requirements the checks for:
- safe_mode=OFF (should be OFF)
- open_basedir not set (should be not set)
... are missing.
Please add these checks to system requirement check.
Additional InformationThis is important, because users reports, that some errors occurs in using updateApp. These errors are not shown when safe_mode is OFF.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

vilma_liorensaityte

2009-10-07 10:51

reporter   ~0001890

Safe Mode is deprecated in PHP 5.3.0 and is removed in PHP 6.0.0.
http://lt.php.net/features.safe-mode

dainius.bigelis

2009-10-07 10:52

reporter   ~0001891

Initialy the problem occured because some warnings in updateApp script.
There are safe_mode directive used in this script.

So please fix this script, that this directive should not be used, then problems because safe_mode will be solved.

vilma_liorensaityte

2009-10-20 13:16

reporter   ~0001931

safe_mode problem solved in updateApp and added open_basedir check