View Issue Details

IDProjectCategoryView StatusLast Update
0001291OXID eShop (all versions)4.06. Language and translationspublic2009-09-28 14:38
Reportersascha 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.3 revision 19918 
Target VersionFixed in Version4.1.6 revision 22740 
Summary0001291: empty basket after language was changed under SSL
Descriptionreproduceable at http://www.presentationload.de/

This shop is available in three languages with own SSL-Domains.

If i change the language during the order process(reproduced in step2), the basket will be emptied.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

dominik_ziegler

2009-09-04 16:24

reporter   ~0001659

I think you get for each domain a new cookie and therefore a new session id. This results in an empty basket, because you have at each domain an other session id. Perhaps you can solve this problem by usind the old session id url parameter.

arvydas_vapsva

2009-09-15 15:14

reporter   ~0001734

fixed

Notice for customers using custom setup for each virtual host - please make sure that php shares session info and session is not differentially stored on/by each host.