View Issue Details

IDProjectCategoryView StatusLast Update
0001047OXID eShop (all versions)3.1. Design, GUI, UXpublic2009-07-30 14:36
Reportertomas_liubinas 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.1.4 revision 21266 
Summary0001047: Firefox doubles HTTP request
DescriptionThere are reported cases when Firefox does not show final order step. It happens because in some cases (most likely under https) Firefox doubles HTTP requests. This is reported specific FF behaviour, I would say FF bug. Some more information on that:
http://brian.pontarelli.com/2006/05/02/is-your-browser-requesting-a-page-twice/
http://forums.mozillazine.org/viewtopic.php?f=38&t=361550&start=0
http://lists.nyphp.org/pipermail/talk/2006-June/018479.html
http://altrupia.com/do/page/blog/Firefox-double-HTTP-request

I noticed double request could be eliminated by removing <meta charset> html tag. Clearly this is not a solution, we need to find out how we can solve it on our side.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Relationships

parent of 0001182 resolvedarvydas_vapsva clear cache of categorys displays 'headers already sent' 
has duplicate 0001043 resolvedalfonsas_cirtautas Econda emos_paging_billing array not filled correctly in Firefox 

Activities

sato-san

2009-07-03 11:40

reporter   ~0001144

[EN]

Hello,

I can reproduce this bug with Firefox 3.0.11 and 3.5, but I think this is not a Firefox Bug.

Reason:
I can reproduce this bug ONLY if I order as guest in the Shop. If I make an account/login before purchasing, there is no error.

My guess:
There is a module, which creates an error. The default setting of an Oxid-Shop is to show the homepage if an error occouse. (Voting module, Recommendation module ... ) The econda Tracking can not start, becauce econda can not tracking the billingPageArray and basketPageArray from the homepage.

If you have any question about it, please let me know.


Kind regards,
René Sato

econda GmbH
[/EN]

[DE]

Hallo,
ich kann den Fehler mit Firefox 3.0.11 und 3.5 reproduzieren, bin jedoch der Meinung, dass es kein Firefox Problem ist.

Begründung:
Ich kann den Fehler nur reproduzieren, wenn ich eine Bestellung als Gast im Shopsystem durchführe. Erstelle ich ein Account und bestelle anschließend, ist der Fehler mit Firefox nicht vorhanden!

Meine Vermutung:
Es gibt ein Modul im Shop, welches einen Fehler produziert. Wird im Oxid Shop ein Fehler erstellt, dann wird immer die Startseite angezeigt. (Zum Beispiel könnte die Ursache von einem Bewertungsmodul oder Empfehlungsmodul sein.)
Das econda Tracking funktioniert nicht, da die thankyou.tpl nicht angezeigt werden kann. econda kann das billingPageArray und basketPageArray nicht aus der Startseite lesen.

[/DE]

Viele Grüße,
René Sato

econda GmbH

andreas_ziethen

2009-07-07 12:24

reporter   ~0001154

Last edited: 2009-07-07 12:25

This thing did cost us half a day of debugging ... :-(
And indeed it seems to be a Firefox Bug. During Debugging we could clearly show that the request was executed twice - this leads to a redirect in the init() method of the thankyou class because at the second time there's no basket in session cause it's been deleted during first request.

A solution is needed very urgently!! So I'd like to see a much higher priority level here then "normal".
SSL is used in nearly each shop and the tracking issue is very important!

alfonsas_cirtautas

2009-07-27 13:42

reporter   ~0001280

looks like our problem : https://bugzilla.mozilla.org/show_bug.cgi?id=236858

Stefan_Werner

2009-07-27 16:01

reporter   ~0001283

also happens with firefox 3.0.12

Benutzer

2009-07-30 08:38

reporter   ~0001321

It's happens in our shop EE 4.1.3 too. As already be sad by other users, it happens only if we use FF (3.0.12).

alexk

2009-07-30 10:30

reporter   ~0001323

Yeap, we have it also ... FF 3.0.12 with EE 4.1.3

alfonsas_cirtautas

2009-07-30 14:36

reporter   ~0001329

Last edited: 2009-08-02 12:22

workaround:

add Http header:

header("Content-Type: text/html; charset=".oxLang::getInstance()->translateString( 'charset' )); // #M1047 Firefox duplicated GET fix
 
before line (PE 301/EE 376):

echo ( $sOutput );