View Issue Details

IDProjectCategoryView StatusLast Update
0001016OXID eShop (all versions)1.05. Userspublic2009-06-23 09:10
Reporterstefan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.2 revision 18998 
Target VersionFixed in Version4.1.4 revision 21266 
Summary0001016: Parsing of special charactes like "&" is not correctly handled
DescriptionWe currently had an issue were an user registered an account with his whole company name, e.g.

"Sample GmbH & Co KG" in the Lastname and Company fields of Oxid PE 4.1.2 version.

The "&" seems to be encoded as html symbol and appears in the database as "&".

So when we view the user data in the adminpanel, the "&" isn't correctly decoded back, resulting in getting the "&" instead of the "&" in the user account fields.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Activities

birute_meilutyte

2009-06-22 14:24

reporter   ~0001097

can not reproduce it. should be investigated from source code side, if such possibility really exist.

vilma_liorensaityte

2009-06-23 09:10

administrator   ~0001104

This bug appears only in Admin->Administer Users->Users->Main/Addresses