View Issue Details

IDProjectCategoryView StatusLast Update
0000844OXID eShop (all versions)4.09. SEO, SEO URLpublic2012-12-10 13:35
Reportersimply because 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.1 revision 18442 
Target VersionFixed in Version4.1.3 revision 19918 
Summary0000844: Dots and commas are deleted from title, META description and META keywords
DescriptionWhen dots and commas are inserted into title, META description or META keyword, these characters are deleted.
Commas and dots should not be deleted from these fields.

Additional Informationstart page - meta description
Please insert:
exactly the words with upper and lower cases, commas and dots in the way they are saved in "oxstartmetadescription".

start page - meta description
commas will be placed behind every word which is not correct.
Please insert:
exactly the words with upper and lower cases, commas and dots in the way they are saved in "oxstartmetakeywords".



category page - title
Please insert:
title of the current category with upper and lower cases, commas and dots in the way they are saved.

category page - meta description
the words from the breadcrump navigation are insert in it.
Please insert:
current category - words with upper and lower cases, commas and dots in the way they are saved in oxlongdesc of current category
or
current category - insert a new field in database for a description used for meta descrition which will insert the words in this with upper and lower cases, commas and dots in the way they are saved in it.

category page - meta keywords:
Please insert:
title of current category



details page - title
Please insert:
title of current item with upper and lower cases, commas and dots in the way they are saved.

details page - meta description
Please insert:
title of current item - oxlongdesc with upper and lower cases, commas and dots in the way they are saved (up to 260 chars).

details page - meta keywords
Please insert:
"oxsearchkeys" with upper and lower cases, commas and dots in the way they are saved.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Activities

dainius.bigelis

2009-04-29 14:10

reporter   ~0000824

I reproduced this case accidently and only once, but cannot reproduce it any more.
The special chars, like commas are stored in the DB as html entities.

@developers: please check from the source code - when the special chars (or html entities) can be deleted from the META descriptions/keywords or titles, and fix it.

rimvydas_paskevicius

2009-05-26 15:42

reporter   ~0000958

All changes done and additionaly details page meta keywords changed to: article title + breadcrumb +"oxsearchkeys"

simply because

2009-06-26 17:30

reporter   ~0001120

This issue is not completely solved with PATCH_OXID_ESHOP_PE_V.4.1.2_18998_TO_V.4.1.3_19918

The shop still put commas between words that are saved under Ident oxstartmetakeywords.

If you save these words:

online shop, cheap stuff

it will be shown as

online, shop, cheap, stuff

rimvydas_paskevicius

2009-07-27 12:59

reporter   ~0001279

Updated metata keywords getter - if keywords are loaded from oxcontent table, no dublicated words are removed and do not splited by space sign.