View Issue Details

IDProjectCategoryView StatusLast Update
0000821OXID eShop (all versions)2. ----- eShop backend (admin) -----public2009-06-30 13:06
Reporterheikereuter 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1.0 revision 17976 
Target VersionFixed in Version4.1.4 revision 21266 
Summary0000821: delete article from shop causes error message in Bestellungen->Stamm
DescriptionWhen an article is deleted from shop oxarticles via shop admin but there is an order where that articled was ordered before delete, Bestellungen->Stamm shows

oxNoArticleException-oxArticleException---!--NOT CAUGHT--!--oxException (time: 2009-04-22 18:47:25): [0]: EXCEPTION_ARTICLE_ARTICELDOESNOTEXIST ...

TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
MySQL Version5.0.33

Relationships

related to 0000819 resolvedarvydas_vapsva Impossible to update order (admin interface) if one of ordered products were deleted from eshop 
related to 0000820 resolvedarvydas_vapsva recalculateOrder in Shop-Admin for existing order 

Activities

dainius.bigelis

2009-04-23 13:03

reporter   ~0000799

In case if such product "cannot be deleted" because the loss of information - the appropriate message should be displayed for user in this case (when he tries to delete the article, which is already bought for someone)), like "This product cannot be deleted as order information is already in Order history. Please disactivate it instead of deleting."
.. Just one of solutions...

dainius.bigelis

2009-04-23 13:08

reporter   ~0000800

For me the lower frame is shown as "Page Not Found", and the error displayed in FireFox is:
oTransfer is null
[Break on this error] oTransfer.oxid.value=sID;
index.php (line 164)

dainius.bigelis

2009-05-08 08:51

reporter   ~0000877

Last edited: 2009-05-08 08:54

Fix needs important changes in the core places, what causes a high risk. So fix will be implemented in Next Major release.

arvydas_vapsva

2009-06-30 13:06

reporter   ~0001124

improved order recalculation now solves this problem.