View Issue Details

IDProjectCategoryView StatusLast Update
0000692OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:38
ReporterCarolin 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version4.1.0 revision 17976 
Summary0000692: IE7 with ICQ Toolbar User's aren't able to order something
DescriptionThere's an issue with all shops (CE, PE, EE) by using IE 7 with ICQ Toolbar.

Start IE 7 and move to: http://www.icq.com/download/toolbar/index_ger.html
Install it to IE 7.

Now visit one of your shops.
For example: http://demoshop.oxid-esales.com/professional-edition/

Try to put something to your basket. Now you will be redirected to http://search.icq.com/search/afe_results.php?q=demoshop.oxid-esales.com%2Fprofessional-edition%2Findex.php?&ch_id=tbtb_ver=3.1.0.0

If you now move back to the shop, the item you put to your basket is there. But you can't buy the article. Because the error occurs also, if you want to move to basket step 3.

It isn't a problem with Firefox3 and ICQ Toolbar.

I haven't any idea why this happens. If you got a solution, please post the corrected code to a comment.

Kind regards,
Carolin Krieg
TagsNo tags attached.
Theme
BrowserInternet Explorer 7.x
PHP Version5.2.6
MySQL Version5.0.33

Relationships

has duplicate 0000732 closed Shop start page always deliveres a 404-header if parameters are added for tracking 

Activities

Carolin

2009-03-11 12:41

reporter   ~0000551

Last edited: 2009-03-11 13:08

With ieHTTPHeaders you can watch the headers like LiveHTTPheaders in Firefox:

http://www.brothersoft.com/iehttpheaders-13615.html

Here are two files with sended headers in IE7.

Once without icq toolbar and once with icq toolbar.

http://88.198.10.107/download/httpheaderie7notoolbar.pdf
http://88.198.10.107/download/httpheaderie7toolbar.pdf

dainius.bigelis

2009-03-12 14:57

reporter   ~0000556

Reminder sent to: Carolin

Hi,

Could you please give me the link to the ICQ toolbar for FireFox and Opera?
As this one which you posted is only for IE7 browser, and I cannot find the same for other browsers.

Best regards,
Dainius Bigelis

Carolin

2009-03-12 15:13

reporter   ~0000557

Last edited: 2009-03-12 15:14

Hi,

the problem didn't occur with Firefox and ICQ-Toolbar. I've just tested this.

If you want to download it, visit the same link with Firefox.
http://www.icq.com/download/toolbar/index_ger.html

direct download link: http://cf.icq.com/toolbar/ff/update/1.1.4/icqtoolbar-1.1.4.xpi

At the moment there isn't an ICQ toolbar for Opera available.

I also get hints that in certain cases also in Firefox 3 this two things didn't work. (Put somethin to your basket and move to step 3). But at moment I can't say with which add-on or toolbar it occurs.

Kind regards,
Carolin

dainius.bigelis

2009-03-12 17:44

reporter   ~0000560

Last edited: 2009-03-12 17:45

Reminder sent to: Carolin

Hi,

The addons, which you refered for IE7 and FireFox - are different in functionality ant version.

Addon for Firefox:
http://cf.icq.com/toolbar/ff/update/1.1.4/icqtoolbar-1.1.4.xpi
is the ICQ toolbar version 1.1.4 for FireFox.

Addon for IE7:
http://www.icq.com/download/toolbar/index_ger.html
(page not found currently, but original page would be:
http://download.icq.com/download/toolbar/?icid=nav_tb)
here you can find the addon:
http://cf.icq.com/cf/toolbar/ICQToolbarSetupUnicodeEng_v31.exe
.. which works only for IE7. And the version of this addon is:
- Version 3.0 Beta
(you can see it when installed in ICQ -> Help...)

And after few minutes work it looks like really buggy.
So I don't agree that problem is in OXID eShop.

dainius.bigelis

2009-03-12 17:46

reporter   ~0000561

Problem is in ICQ toolbar, not in OXID eShop.

Carolin

2009-03-12 18:03

reporter   ~0000562

Last edited: 2009-03-12 19:15

This morning my link works fine.

I know that there are different versions for IE and FF but I never told, there is a problem with Firefox and ICQ Toolbar.

But IE7 and ICQ toolbar didn't work.

Today we got the 5th appeal, that users couldn't order something (in 2 weeks!). And not all people who can't order announce it!

The problem is the 404 header which oxid sends. And you send it all times, with and without Toolbars! And this cause the errors.

HTTP/1.x 404 Not Found
Date: Thu, 12 Mar 2009 18:10:16 GMT
Server: Apache
X-Powered-By: PHP/5.2.8
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Set-Cookie: sid=c9230e9e450da48f63b97abd2707c522; path=/
Vary: User-Agent,Accept-Encoding
Content-Encoding: gzip
Content-Length: 8932
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html


And there are also users with Firefox. I don't know which add-ons they use, but they get "Page not found" after put something to their basket.

Carolin

2009-03-12 18:31

reporter   ~0000563

And when I decide to use AVG toolbars (Anti-Virus and Internet Security) (with default values) in FF or IE it's also fine that I couldn't buy something?

Clonewares

2009-03-12 18:54

reporter   ~0000564

Still the same problem with IE 6 and IE 7.

stephen

2009-03-14 01:04

reporter   ~0000571

Hi guys,

the problem is the 404 header. If you put something into your basket you first get a 301 and then a 404.

The same from step 2 to step 3.

The problem Carolin experiences is also named "404 hijacking". There are many toolbars on the market and some of them pick 404 pages and redirect the user to the respective search engine.

Please make use of Live HTTP headers, look at it and fix the bug. It's really obvious!!!!!

Regards
Stephen

csimon

2009-03-14 19:29

reporter   ~0000576

the problem is in oxubase.php where, in line 217 the 404 header is sent, if no SEO url for a site is found. That matches for the most (or all) urls which have a "?cl=xxx" parameter or any other GET Parameters. The 404 is sent, but it outputs the right page.

ralf_trapp

2009-03-16 08:41

reporter   ~0000578

Check also hints on http://www.oxid-esales.com/de/resources/forum/installation-und-konfiguration/bug-im-ie-7-mit-icq-toolbar (esp. my comment)

Ralf

arvydas_vapsva

2009-03-16 15:54

reporter   ~0000584

The problem appears due to SEO implementation.

Normally, if executed URL is not in SEO form, shop tries to translate it in SEO, emits 302 header and redirects to alternative page, thus telling to search engines/regular browsers to forgot old, non seo mode page and forces usage of new one. This is usefull when shop is updated from old to new.

But some URLs cannot be translated into SEO form and usually they should not be accessed by SE, but should be finely rendered for regular users. So on such case we came to idea that by passing 404 header (see php function header()) SE will ignore content and stop indexing, but customer will be able to execute standard process, because after emitting 404 header we continue default output.

Seems like this approach does not work, so we could solve it by adding special "noindex, follow" meta tags instead of emitting 404 header.

Agreed ?

csimon

2009-03-16 22:21

reporter   ~0000586

yes, this is a better approach than the one before. thanks!