View Issue Details

IDProjectCategoryView StatusLast Update
0000632OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:38
ReporterCarolin 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version4.1.0 revision 17976 
Summary0000632: Saving shopping basket for user does not work
DescriptionSettings:
http://demoshop.oxid-esales.com/professional-edition/admin/
Main Menu -> Core Data -> Perform.

unchecked: Disable shopping basket saving for user
____________________________________________________________

Now I am moving to your site:
http://demoshop.oxid-esales.com/professional-edition/
Login -> user: admin pw: admin

I add the "Original BUSH Beach Radio" to my basket.

Logout -> restart Browser
Login -> user: admin pw: admin

Expected Result:
"Original BUSH Beach Radio" is still in my basket.

RESULT:
My basket is empty.

In my opinion this is a bug because the basket is empty, although I didn't select the option "Disable shopping basket saving for user".
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

arvydas_vapsva

2009-03-02 09:18

reporter   ~0000512

Last edited: 2009-03-02 09:19

Fix in oxbasket::_mergeSavedBasket():

Wrong:
    $this->addToBasket( $oItem->getId(), $oItem->dAmount, $oItem->aSelList, null, true );

Good:
    $this->addToBasket( $oItem->oxuserbasketitems__oxartid->value, $oItem->oxuserbasketitems__oxamount->value, $oItem->getSelList(), null, true );

Carolin

2009-03-05 13:26

reporter   ~0000526

Thanks for the fix. I've tried it and saving basket for users works.

But there's a problem with the "remove" function in basket step 1.

I'm a registered User and put something to my basket. Then I decide to remove some items or all items (basket step 1).

On next visit (new session) all products will be displayed again, also the removed items.

If you want to take a closer look on this bug visit:
(we've integrated your solution to this PE 4.0.1.0)

http://www.hardcore-bb-shop.de
User: 11420
PW: testumgebung

It's our test environment. So feel free to order.

It would be great to find your solution in a comment.

Kind regards,
Carolin Krieg

arvydas_vapsva

2009-03-09 15:02

reporter   ~0000535

Due to bug in code history renewal only worked when adding products to basket. Buggy code:

    if ( !$blBundle && !$blRemoveItem ) {
        $this->_addItemToSavedBasket( $this->_aBasketContents[$sItemId]->getProductId(), $dAmount, $aSel, $blOverride ) );
    }

Fine code:

    if ( !$blBundle ) {
        $this->_addItemToSavedBasket( $sProductID, $dAmount, $aSel, $blOverride );
    }