View Issue Details

IDProjectCategoryView StatusLast Update
0006886OXID eShop (all versions)6. ------ Setup -------public2022-01-28 10:14
Reporterkaluzki 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0006886: exclude tests from dist-packages
Description@see https://madewithlove.be/gitattributes/
TagsComposer, Git
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

QA

2018-08-16 09:59

administrator   ~0012583

Last edited: 2018-08-16 10:00

View 2 revisions

The testing library is included for development purpose but can be excluded during installation with the paramater --no-dev, which is recommended for a production installation.
It is described in our docs: https://docs.oxid-esales.com/developer/en/6.1/getting_started/installation/eshop_installation.html

I would consider this as a sufficient option.

[sp]

kaluzki

2018-08-16 11:07

reporter   ~0012584

Its not about the testing library, but about the test files, which are included in almost every composer package:

vendor/oxid-esales/oxideshop-ce/tests
vendor/oxid-esales/oxideshop-doctrine-migration-wrapper/tests
vendor/oxid-esales/oxideshop-facts/tests
vendor/oxid-esales/paypal-module/Tests
etc.

With the option "--prefer-dist" you can let composer to analyse .gitattributes file for "export-ignore" occurences and to shrink the package.
For more details see https://madewithlove.be/gitattributes/

Its a wide-spread approach anyway:

* https://github.com/zendframework/zend-http/blob/master/.gitattributes
* https://github.com/laravel/framework/blob/master/.gitattributes
* https://github.com/composer/composer/blob/master/.gitattributes

naehwelt

2018-11-29 09:00

reporter   ~0012707

see PL https://github.com/OXID-eSales/oxideshop_ce/pull/673

Sven Brunk

2022-01-28 10:13

administrator   ~0013529

This feature has been rejected by the team and since there are good reasons not to separate tests and the code it is testing while at the same time there are easy ways for all projects to remove the tests for their distribution in the CI pipeline, we will not do this.