View Issue Details

IDProjectCategoryView StatusLast Update
0003361module PayPalmodule PayPal - subpublic2012-12-10 16:10
Reportermichael_keiluweit 
PriorityurgentSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003361: PayPal is not working with latest CURL version
DescriptionWith the latest CURL Version it's not possible to use PayPal because CURL uses only TLS, not SSL.
Here's the error message:

Error: curl-errorCode: 56 - curl-errorMessage: GnuTLS recv error (-9): A TLS packet with unexpected length was received.

To fix it, a curl option musst be changed to "curl_setopt($ch, CURLOPT_SSLVERSION, 3);"
Additional InformationI guess it's the best way to set a new config parameter to change it as the customer need it.
TagsNo tags attached.

Activities

ecom-software

2011-11-08 14:56

reporter   ~0005373

The Shopversion is 4.4.8 and the eFire PayPal Modul MOD_PAYPAL_1.5.13_32697

To fix this problem it's better to set this value to

curl_setopt($ch, CURLOPT_SSLVERSION, 3);